Meteor Upgrade

We’ve all known meteor needs and upgrade for a while now.

My experience with Meteor is limited mostly to this project. I’m going to be running some experiments desk side to see what this’ll take. Operations like this are what we need a robust testing framework for.

2 Likes
`   While selecting package versions:
   error: Potentially incompatible change required to top-level dependency: mongo 1.4.7, was 1.6.2.
   Constraints on package "mongo":
   * [email protected] <- top level
   * [email protected]~1.4.2 <- top level
   * [email protected] <- autoupdate 1.4.0 <- hot-code-push 1.0.4 <- meteor-base 1.3.0
   * [email protected] <- service-configuration 1.0.11
   * [email protected] <- accounts-base 1.4.2 <- alanning:roles 1.2.16
   * [email protected] <- aldeed:collection2 3.0.0
   * [email protected] <- alanning:roles 1.2.16
   * [email protected] <- sylque:accounts-discourse 0.0.5

   Potentially incompatible change required to top-level dependency: standard-minifier-css 1.4.1, was 1.5.3.
   Constraints on package "standard-minifier-css":
   * [email protected] <- top level
   * [email protected]~1.4.0 <- top level

   Potentially incompatible change required to top-level dependency: standard-minifier-js 2.3.4, was 2.4.1.
   Constraints on package "standard-minifier-js":
   * [email protected] <- top level
   * [email protected]~2.3.1 <- top level

   To allow potentially incompatible changes to top-level dependencies, you must pass --allow-incompatible-update on the command line.`

Then running the update:

    10:36 $ meteor update --allow-incompatible-update
    fl-maps: updated to Meteor 1.8.1.
    Changes to your project's package version selections from updating package versions:

    accounts-base                   upgraded from 1.4.3 to 1.4.4
    aldeed:collection2              upgraded from 3.0.0 to 3.0.2
    ardatan:webpack                 upgraded from 0.0.5_7 to 0.0.13
    ardatan:webpack-dev-middleware  upgraded from 0.0.5 to 0.0.13
    base64                          upgraded from 1.0.11 to 1.0.12
    ecmascript                      upgraded from 0.12.4 to 0.12.7
    mdg:validated-method            upgraded from 1.1.0 to 1.2.0
    mongo                           upgraded from 1.6.2 to 1.6.3
    sylque:accounts-discourse       upgraded from 0.0.5 to 0.0.7
    webapp                          upgraded from 1.7.3 to 1.7.4


    Newer versions of the following indirect dependencies are available:
     * raix:eventemitter 0.1.3 (1.0.0 is available)
    These versions may not be compatible with your project.
    To update one or more of these packages to their latest
    compatible versions, pass their names to meteor update,
    or just run meteor update --all-packages

Starting the project:

10:37 $ meteor npm run start

\> [email protected] start /Users/mcnultt/Documents/Projects/fl-maps
\> meteor run --settings settings.json

[[[[[ ~/Documents/Projects/fl-maps ]]]]]

=> Started proxy.
Unexpected mongo exit code 62. Restarting.
Unexpected mongo exit code 62. Restarting.

The above exit code 62 is what I was getting as well - necessitated restarting the db (wiping it); or in our case probably patching it as discussed :crossed_fingers: