Bcrypt bug preventing setting up Local Host versions

@ReactMeteor and @SysAdmin, there seems to be a new issue preventing developers working on the Reactjs and Meteor side of the platform from setting up a local instance to build on.

@zdbrenda or @ludanin, can one of you please post the error logs here and any other relevant details.

Also, does anyone know any Meteorjs forums we can ask on? Meteor is planning on a big comeback at the start of next year and hopefully devs there will be extra eager to help an ambitious opensource homelessness project.

node_fail.doc (825.5 KB)
It’s actually a plaintext file but it seems we can’t upload these here – so if you have any problems opening it just rename it to an extension your OS recognizes.

1 Like

These solutions are pretty old, but it does look like this has been a common error devs have encountered with Meteorjs, and there are a few potential solutions in this thread you can try:

Here’s a solution from July 4th this year:

Here’s a different solution from last year which blames the problem on an incorrect url:

Hopefully if you guys try these out one will solve the issue. If you succeed please create documentation for this error and fix as it looks like everyone is going to run into it.

Oh, one more thought @zdbrenda and @ludanin. You guys aren’t trying to set up n Windows are you, as that’s always a pain in the ass.

Thanks for finding a solution, I’ll try to see if it works after work!

Oh, one more thought @zdbrenda and @ludanin. You guys aren’t trying to set up n Windows are you, as that’s always a pain in the ass.

Nope, and whenever I develop on a Windows I make sure to use WSL – because yeah, making anything work on Windows is a real pain in the ass haha.

1 Like

@tmcnulty tried to recreate your issues yesterday and the setup worked fine for him… which isn’t much help in identifying the issue, but it does show that there is a way to get it running. He was following the same guide, maybe he had a required framework or something on his PC. Anyway, hopefully the steps above will solve it.

@ludanin Can you try changing line 17 in package.json to

 "bcrypt": "3.0.6",

I’m working on moving branches and repos around but I’ll push a change up for that.


Tagging @zdbrenda and @kentokana. Hopefully we good to go and can get that homepage up now :slightly_smiling_face::sunglasses:

Thanks for your good work @tmcnulty

This fixes the bug!! The week has ended so I’ll finally have time to work on this haha, I’ll try to have some good results up by Sunday, but in case not I’ll push anything that I have to GH so someone else can continue.



Great news! Thank you for sticking with it through this unexpected bug :smiley: