NPM run error - bcrypt - babel

I am getting this error when running meteor npm install

I ran npm install node-pre-gyp -g which was successful, but then when I was running meteor npm install I was still getting the same error.

1 Like

I haven’t seen that error message before.

You could try messaging @kentokana as they just successfully set up a local host a few days ago.

When you find an answer it would be great to add the error and fix hereothers who encounter it in the future for : Getting Started: Setting Up a Local Dev Environment - and related bug fixes

1 Like

@kentokana do you have any idea why did I get the error when I was running meteor npm install after I had successfully installed node-pre-gyp? Thanks.

1 Like

@WebDev @ReactMeteor has anyone seen this error before?

I have found the log but no sure what keyword should I try first. I have put the log in my google drive.

log for the installation

1 Like

Ah, I have some idea now.

`node-pre-gyp info it worked if it ends with ok
node-pre-gyp info using [email protected]
node-pre-gyp info using [email protected] | darwin | x64
node-pre-gyp WARN Using needle for node-pre-gyp https download 
node-pre-gyp ERR! install error 
node-pre-gyp ERR! stack Error: fl-maps-react package.json is not node-pre-gyp ready:
node-pre-gyp ERR! stack package.json must declare these properties: 
node-pre-gyp ERR! stack main
node-pre-gyp ERR! stack version
node-pre-gyp ERR! stack binary.module_name
node-pre-gyp ERR! stack binary.module_path
node-pre-gyp ERR! stack
node-pre-gyp ERR! stack     at validate_config (/usr/local/lib/node_modules/node-pre-gyp/lib/util/versioning.js:220:15)
node-pre-gyp ERR! stack     at Object.module.exports.evaluate (/usr/local/lib/node_modules/node-pre-gyp/lib/util/versioning.js:279:5)
node-pre-gyp ERR! stack     at install (/usr/local/lib/node_modules/node-pre-gyp/lib/install.js:241:31)
node-pre-gyp ERR! stack     at Object.self.commands.<computed> [as install] (/usr/local/lib/node_modules/node-pre-gyp/lib/node-pre-gyp.js:52:37)
node-pre-gyp ERR! stack     at run (/usr/local/lib/node_modules/node-pre-gyp/bin/node-pre-gyp:82:30)
node-pre-gyp ERR! stack     at Object.<anonymous> (/usr/local/lib/node_modules/node-pre-gyp/bin/node-pre-gyp:134:1)
node-pre-gyp ERR! stack     at Module._compile (internal/modules/cjs/loader.js:1063:30)
node-pre-gyp ERR! stack     at Object.Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
node-pre-gyp ERR! stack     at Module.load (internal/modules/cjs/loader.js:928:32)
node-pre-gyp ERR! stack     at Function.Module._load (internal/modules/cjs/loader.js:769:14)
node-pre-gyp ERR! System Darwin 20.5.0
node-pre-gyp ERR! command "/usr/local/bin/node" "/usr/local/bin/node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd /Users/dan/Documents/fl-maps/fl-maps
node-pre-gyp ERR! node -v v14.16.1
node-pre-gyp ERR! node-pre-gyp -v v0.17.0
node-pre-gyp ERR! not ok 
fl-maps-react package.json is not node-pre-gyp ready:
package.json must declare these properties: `

It seems like something wrong with package.json file.

1 Like

It should be correct, but just to be sure find the one i uploaded to google drive on the current getting started guide. If you send me a request i’ll approve it.

…although i wonder, @zofrex and @tmcnulty, has changing the DB keys made our current settings.json file obsolete? If so can you please send me an updated one?

Ah hey @zdbrenda, I vaguely recall having an issue like this in my initial installation (referring to your screenshot). That said, this issue didn’t present itself on my 2nd clean install attempt, so I didn’t think this was a consistent issue. :confused:

In my case, I think there was an issue with the bcrypt package listed in package.json. As documented in over in NPM (bcrypt - npm), Bcrypt above version 3.0.6 is necessary if you run the application Node version 12+. So I believe I modified the bcrypt version in package.json to be ^3.0.6. Here’s another reference to the error: can't install bcrypt.js · Issue #766 · kelektiv/node.bcrypt.js · GitHub

Again, keep in mind that I did a new clean install of the fl-maps project and it works fine without modifying the package.json. :man_shrugging: but it might be worth a try!


Thanks @kentokana and @zdbrenda for finding this. It looks like a bug that’s going to trouble more people in the past. Would you recommend updating something, or is it safer to add Kento’s workaround to the getting started guide to fix this?

1 Like

Now I have another error when running npm run start

The error is here:

W20210802-19:29:04.424(-6)? (STDERR) /Users/dan/Documents/fl-maps/fl-maps/.meteor/local/build/programs/server/boot.js:475
W20210802-19:29:04.484(-6)? (STDERR) }).run();
W20210802-19:29:04.488(-6)? (STDERR)    ^
W20210802-19:29:04.489(-6)? (STDERR) 
W20210802-19:29:04.489(-6)? (STDERR) Error: Cannot find module '@babel/runtime/helpers/builtin/interopRequireDefault'
W20210802-19:29:04.489(-6)? (STDERR)     at Function.Module._resolveFilename (module.js:547:15)
W20210802-19:29:04.489(-6)? (STDERR)     at Function.resolve (internal/module.js:18:19)
W20210802-19:29:04.490(-6)? (STDERR)     at Object.require (/Users/dan/Documents/fl-maps/fl-maps/.meteor/local/build/programs/server/boot.js:288:32)
W20210802-19:29:04.490(-6)? (STDERR)     at makeInstallerOptions.fallback (packages/modules-runtime.js:651:18)
W20210802-19:29:04.490(-6)? (STDERR)     at require (packages/modules-runtime.js:244:16)
W20210802-19:29:04.490(-6)? (STDERR)     at livedata_connection.js (/Users/dan/Documents/fl-maps/fl-maps/.meteor/local/build/programs/server/packages/ddp-client.js:147:30)
W20210802-19:29:04.490(-6)? (STDERR)     at fileEvaluate (packages/modules-runtime.js:343:9)
W20210802-19:29:04.491(-6)? (STDERR)     at require (packages/modules-runtime.js:238:16)
W20210802-19:29:04.491(-6)? (STDERR)     at namespace.js (packages/ddp-client/common/namespace.js:1:300)
W20210802-19:29:04.491(-6)? (STDERR)     at fileEvaluate (packages/modules-runtime.js:343:9)

Hey, I am still trying to solve the above error to get my local dev env running. I could only seem to find this related link , but it doesn’t solve the issue: Upgrade 1.7 Issue with @babel/runtime - help - Meteor.js forums

Can someone please help me with it?

I have "@babel/runtime": "^7.14.8" in my package.json file and node_modules/@babel/runtime/helpers/builtin folder doesn’t exist.

1 Like

I didn’t go through this. I set up the discourse project using yarn. I didn’t have to do this in the plugin development aspect as well.

This is new for me.

1 Like

@zdbrenda Are you trying to set up discourse locally?

1 Like

Thank you for replying @Marvelxy. This is for setting up the React side of the app as the Discourse side takes a lot of dependencies and getting them to communicate is difficult to do locally. Its great that you got it working though, i’m sure others will love to follow your guidance in the future :slight_smile:

1 Like

Oh, I see. Well, If anyone needs help in setting up Discourse, I will surely assist.

1 Like

Hey Brenda,
This type of error is very common in projects like this. I can’t reproduce this at the very moment but you can try a few things like altering the version number to some previously available versions. You can also see if you can track down what’s different between the versions that are conflicting and alter or remove logic that’s conflicting.

I’m not sure if these exact pages will help but they’re where I would start to compare/find versions that may not halt startup.

Node-semver for info on parsing versions.

I’ll let you know if I’m able to take a look and reproduce or start with a different version.

1 Like