PHM not building. Error: Cannot find module './mup-secrets.json'

@SysAdmin PHM is not building anymore. It seems to have broken whilst upgrading Meteor to the most recent version.

The error message in Travis:

Error: Cannot find module './mup-secrets.json'

I had a little look and this file: fl-maps/mup.js at deploy-phm · focallocal/fl-maps · GitHub

is looking for mup-secrets.enc.json in line one. That files doesn’t exist in our codebase.

I’ve tried both:

Both of which failed so i reverted the changes. It looked like they had dependencies elsewhere.

@zhna123 you came across this issue when setting up localhost didn’t you? How did you resolve it?

Its fairly unlikely, but the linting fix Na did was at about the same time.

It all looks like tidying up to me, but i would appreciate it if someone could scroll down to the two mup and secrets files and just double check those couldn’t have caused the issue: Fixed linting issues by zhna123 · Pull Request #1162 · focallocal/fl-maps · GitHub

I got the app running in my local by renaming the secret file(remove .enc).

On the server, however, I saw this line to decrypt the secret files: fl-maps/.travis.yml at deploy-phm · focallocal/fl-maps · GitHub I haven’t done much bash stuff… and I assume this is correct, but, may still worth a try to see if the mup-secrets.json is actually generated.

I also had a quick look at the 2 recent builds you did, @AndyatFocallocal it seems they didn’t have the original cannot find mup-secret.json error anymore, instead, there was some authentication error, ie, Error: All configured authentication methods failed

I just did a quick googling, and found the following, and maybe you can try what was suggested there: Mup Setup and Deploy fail - All configured authentication methods failed · Issue #974 · zodern/meteor-up · GitHub

But, of course, we have to figure out why the secret file can’t be found.

1 Like

Thanks for finding that. Its getting a bit too heavy backend for me but i’ve read through their suggestions and tried to follow. The earlier ones are work arounds. The latter ones seem to suggest a Digital Ocean issue (which is where we are hosted) or an SSL issue, and perhaps the upgrade has led us into that where before we sailed past it.

My thoughts with this error message

Is that its because the file doesn’t exist. If i change the path its looking to match the existing file, or change the file name to match that path, then something else in the build which is pointing at one of those can’t find it. If its not something deeper going on like they are talking about in the thread you found.

Hmm, it’s strange the authentication error only happens if you change the mup-secret.enc.json name or the path from mup.js file. mup setup was actually successfully without these changes. Not sure how they relate… But did you find the decrypted secret file on the server? Or you already checked and it’s not there?

1 Like

I’ve asked @tmcnulty if he can see the file on there. Just waiting for an answer. Same for the Teleport 2FA reset. He sometimes has busy periods at work and doesn’t come around here for a while