Small Bug. Admin button doesn't work

@syl there’s a small bug i’ve been ignoring for a while, i’m not sure i’ve mentioned it or not.

If i click the Admin button to view the admin account, the site fails to load that page. If i enter it in manually in the address bar it loads fine. With Docuss disabled the expected behaviour returns.

Its only a mild inconvenience

I’ll have a look at this on Monday.

Please try to replace this line with:

<Route exact path={routePaths.admin} render={props => <Admin {...props}  {...dcsProps} />} /> 

and let me know the result.

And also, please replace those 2 lines with:

<Route exact path={routePaths.root} render={props => <Home {...props} {...dcsProps} />} />
<Route exact path={routePaths.home} render={props => <Home {...props} {...dcsProps} />} />

which file will those be in @syl ?

The file I’ve linked: /imports/client/ui/app.js

Oh, sorry I missed the links somehow. Will do it early tomorrow

@syl we’re currently using the master_withoutdcs branch and not the master branch. @tmcnulty is currently working on switching them to prevent confusions.

i’ve added the code to what seems to be the same lines in the other branch, it would be good if you’d have a look though as obviously i’ve not changed exactly what you thought i was changing.

It has resolved the issue, so everything looks good. i’d be grateful if you could just review the change to make sure another bug hasn’t slipped in.

@AndyatFocallocal, please revert the change, as I think the website is now broken. I think the fix I proposed cannot work on master_withoutdcs, I need more time to have a look at this branch.

1 Like

ok, thanks

The issue doesn’t seem to be in Docuss, as it doesn’t occur on It’s probably in the way fl-maps uses Docuss, but I didn’t find any clue yet. I will give it another try on Saturday.

your other changes solved it when you were using the master branch as a base. thats a clue :slight_smile:

@syl i’ve got an update.

If i turn either cloudflare or Docuss off it solves this bug so it seems to be a conflict between the two

1 Like

wait… it just occurred again with cloudflare still off.

there’s a hint of whats causing it but its not clear still

@AndyatFocallocal, I’ve reported a more comprehensive description of the issue here, including a workaround.

Still no clue about the reason why it occurs, though.

I’ve deployed a new version of the plugin that might help tracking the bug (it outputs debug infos in the console). Would you please install it?


@AndyatFocallocal, I took the liberty to update the Docuss plugin myself.

1 Like

Cool. Any new features, or all bug smoothing?

Just a debug version to track the “Admin Page” issue.

1 Like

just tagging @tmcnulty here as he said he might be able to have a look at this bug. @syl did you get any ideas on resolving it?