SSO for Brighter Tomorrow Map

I’m moving the discussion here as it involves a few people.

@bob give the app a try and see if it works now. @tmcnulty i’ve copy pasted the SSO settings directly from Discourse in PHM, i’m not sure the implecations of doing that or if we need to create new settings for our SSO server.

i’ve also turned off overriding the avatar and background settings as some users had issues with not being able to upload one. I think its because we don’t have avatar uploads in our React maps yet, so that was just blocking using the site as normal. If anyone can see any issues please let me know.

@zofrex we have a plugin installed twice. I’m not sure if that could be causing the issues bob is experiencing or not

Still not working.

Just to let others know, the user gets redirected to instead of when they login on a mobile browser. I tried to replicate it on Chrome and Firefox on desktop in mobile view but there was no problem. The link for the top left logo that usually links back to the home page is also linking back to the PHM URL.

1 Like

@zofrex I was just searching through the deploy-btm branch for anything with publichappinessmovement and I found this in the settings.enc.json for BTM.
I don’t know much about whats using the settings but shouldn’t the url be

I’m just trying to find out what’s causing the redirect on mobile devices so if this has nothing to do with it then just ignore it.

1 Like

Yes, that looks quite likely to be the issue. Great find Bob!

How can we make that site independent on the same branch @SysAdmin team?

Can we use an i18n link for it to follow instead of stating the URL here?

@zofrex Did you see my post in this topic? Also is it just me or is the BTM home page not loading anymore? It only shows the nav bar.

1 Like

I see the same issue @bob (chrome and Android)

Looks like the server rebooted at ~11:36 (UK time) yesterday and networking failed to come up. I had to power cycle it via the DigitalOcean dashboard. I’m not sure what caused the reboot or why networking failed, but it all seems to be working now.

1 Like

Yep looks like it works now and the redirect bug is fixed so it loads fine on mobile browsers. Thanks for fixing it!

1 Like

I updated that Discourse URL you spotted in the settings file. The deployment finished just now, at 08:54 UK time. I’m not sure if the server reboot or the settings update fixed the redirect? Good news either way!

Edit: And good spot, bob :slight_smile:

1 Like

As for making the setting different for each site, that’s already handled @AndyatFocallocal :slight_smile: we now have a separate settings.json for each website.

1 Like

Well done guys. I’ve got a lead for a Dev that could help with those 2 React tasks. Hopefully we’ll be ready to go soon :slightly_smiling_face::slightly_smiling_face:

@zofrex @tmcnulty @syl@bob too as you found the issue last time. The SSO settings on the testing server are not working. I copied over all the details in the admin section of Discourse, and checked the url here:

I’m not sure what the error is, but it is occurring when a user tried to login on the testing server