Setting up Discourse via the admin section after launching a new site

If you’ve set up your own instance of our Reactjs app and installed a Discourse forum to connect it to, you’re next going to need to put in the correct settings in the admin section before it’ll run properly.

Setting up your new account.
Visit your chosen domain where Discourse is installed and you’ll see the ‘getting started wizard’ which will guide you through the 1st steps.

You should have already installed all the required plugins. If not visit the plugins guide

Turn the plugins on

Turn on all plugins. The settings on most aren’t critical to functionality, you can adjust them as you choose.


  • enable the plugin
  • add a link to the Docuss file in your React platform. In meta it is this one:
  • You can also add any other dcs-website.json files you’ve used on other sites you own if you want Docuss to appear on them.
  • Turn off suggested topics
  • enter the iframe attribute: allow=“geolocation”

Check and adjust your settings in your app

Here you can see the settings in our app which tell Docuss where it should run:


This platform currently uses the ‘Light’ Theme. Many other Themes will work fine so feel welcome to explore them.


Here’s the components we are currently using. This section will need updating when we’ve finished modifying the components to allow Tag Centered navigation. As of this date many of the components we use are being developed and not fully ready for use, or currently turned off as they conflict with others.


Do not reload your site at this point

If you do you’ll be locked out and have to complete the process in safe-mode (which isn’t too hard anyway).

To access safe mode go to:

http://your-site-name/safe-mode then navigate to admin to complete the setup. You may need to disable your theme in the options it gives you, but shouldn’t need to disable the plugins.

More settings

Search for:

Create your 1st post

Create a post in your forum and include the tags ‘dcs-comment’ and “dcs-discuss” in it. Docuss needs a 1st post in order to run.

Common errors

The ‘private’ url in the new settings files you created should have been changed when you deployed you React app. Line 51 here: file)/settings.enc.json (it may be higher in your code, just look for ‘private’)